OpenGL 2.0 renderer not supported error playing Angry Bird : Solved

One of Our Facebook Fan Reported an Error ( OpenGL 2.0 renderer not supported error )on Angry Bird Rio game.He said that “I have installed the free angry birds game on my computer but when I try to play it, windows shows and error”.
OpenGL 2.0 renderer not supported error playing Angry Bird : Solved

” OpenGL 2.0 renderer not supported! Reason: OpenGL 2.0 is not supported”

“OpenGL 1.4 renderer not supported! Reason: OpenGL 1.3 is not supported”

I don’t have any information about this error while playing this video game. Somebody have any solution for this error then please help me to solve it.

Well you can see the Snapshot from the system of that user.So we Searched over the Internet for the same Problem and Found Some Solutions For Windows Xp,Windows 7 and also For Newly launched Window 8.

you can Go through the Threads by your self Here.

  1. http://forums.techguy.org/games/987353-solved-opengl-error-playing-angry.html
  2. http://communities.intel.com/thread/20497
  3. http://www.techhotfix.com/forum/showthread.php/348-Windows-display-OpenGL-error-while-launch-Angry-Birds
  4. http://adf.ly/9pcIi
What we observed from these posts that the main cause of error is Improper Installation of game and Not choosing the inappropriate Graphic driver and second main Reason is outdated Drivers on your PC.
So the First solution is to Update your Video and Graphic Driver and Choose Appropriate Graphic Driver at the Installation Time.

For Windows Xp

a.Right click on desktop
b.Then Goto setting (last tabon display properties)
c.Then click on Appearance tab on bottom right side corner.
d.And Now click on Enable hardware acceleration and Set the bar to full
e.Now click on ok and play the gameFor updating Drivers on your Systema.Go to Windows Update
b.Click the check for update button
c.Check optional updates for an Opengl update
d.If available, check to update
e.Click install
f.If there are no updates listed as optional, go to Open GL site and update drivers from thereOR
Perform the following troubleshooting methods:Method 1:
I would suggest you to update the latest graphics card driver from the manufacturer’s website and then check if this fixes the issue.Follow the steps:

a. Move the mouse pointer to the left bottom corner.
b. You will get “Start: option.
c. Right click and select “Device Manager”.
d. Expand the “Display Adapters”.
e. Right click on the graphics card name and select “Update Driver Software”.

Method 2:

If that doesn’t work, I would suggest you to Uninstall the game, then download a fresh setup file and install it in Compatibility mode.

Follow the steps:

a. Download the game setup file and save it on your local disk.
b. Right click on the setup file of the game and select “Properties”.
c. Select “Compatibility” Tab.
d. Make a check mark next to Run this program in “Compatibility mode” and select the Windows 7.
e. Let the game install and then check the functionality.

For more Details if above mentioned Methods Do not Solve your Problem Watch this Video.

P.S : We have tried and Provide every Best solution from Our Side as We are not Expert on this Please Co-operate and if you still finding Problem on game then Consult the Rovio the makers of game.

4 thoughts on “OpenGL 2.0 renderer not supported error playing Angry Bird : Solved

  • August 3, 2012 at 12:14 pm
    Permalink

    pls install intel graphics media accelerator driver……..
    then reinstall angry bird….it will work….
    just try……

    Reply
  • August 3, 2012 at 3:49 pm
    Permalink

    thank you for Suggesyion Prashil.it worked for the problem but sometime it does not work.

    Reply

Leave a Suggestion/Query/Precious View

This site uses Akismet to reduce spam. Learn how your comment data is processed.